Service Disruption - Login & Payment Outage (Cloudflare)

Incident Report for Tamara

Resolved

This incident has been resolved.
Posted Dec 05, 2025 - 12:16 GMT+03:00

Identified

Dear Valued Merchants and Customers,

We would like to inform you that we are currently experiencing a service disruption impacting User Login and Down Payment Processing services. The issue has been traced to a global outage from our third-party network provider, Cloudflare, which is affecting multiple services worldwide.

Our engineering team is actively working on mitigation by rerouting traffic to alternative resources. We will share an update as soon as the services are restored to full operating capacity.

We sincerely appreciate your patience and understanding.

Regards
Tamara
Posted Dec 05, 2025 - 12:10 GMT+03:00
This incident affected: API, Customer App, Checkout, Partner Portal, Partner App, and Homepage.