Service Disruption: Latency Issue on the App

Incident Report for Tamara

Resolved

This incident has been resolved.
Posted Nov 03, 2025 - 13:23 GMT+03:00

Identified

Dear Valued Merchants and Customers,

We would like to inform you that we are currently experiencing a latency issue on the app, which is impacting customers’ ability to log in, as well as to make down payments and repayments.

Our technical team has identified the root cause, and a war room is in progress to resolve the issue at the earliest. We will keep you updated once the service is fully restored.

We sincerely apologise for the inconvenience and appreciate your patience and understanding.

Best regards,
Tamara
Posted Nov 03, 2025 - 13:07 GMT+03:00
This incident affected: Customer App and Checkout.