Service Disruption - Tamara Global Outage

Incident Report for Tamara

Resolved

This incident has been resolved.
Posted Aug 28, 2025 - 07:38 GMT+03:00

Identified

Dear Valued Merchants and Customers

Due to a technical issue on our end, we are currently experiencing a service disruption thats preventing customers to login and perform the transactions. Our team is actively troubleshooting the problem and working to restore all services as quickly as possible. We will provide an update as soon as we have more information.

Regards
Tamara
Posted Aug 28, 2025 - 07:32 GMT+03:00
This incident affected: Customer App, Checkout, and Homepage.