Service Interruption : Down Payment Issues
Incident Report for Tamara
Resolved
Dear Valued Customers and Merchants,

We are pleased to inform you that the technical glitch impacting down payments has been resolved. All users should now be able to complete their down payments without any issues.We apologize for any inconvenience this may have caused and appreciate your patience and understanding during this time.

Thank you for your continued support.
Posted Jul 16, 2024 - 07:30 GMT+03:00
Identified
Dear Valued Customers and Merchants,

We regret to inform you that we are currently experiencing a technical glitch that is impacting down payments. While this issue is intermittent and does not affect all users, some users are unable to complete their down payments.
Our team is working on resolving this issue with the highest priority. We will keep you updated on our progress.
We apologize for any inconvenience this may cause and appreciate your patience and understanding
Posted Jul 16, 2024 - 07:20 GMT+03:00
This incident affected: Checkout.