Service Disruption - Payment Plan Page Infinite Loading

Incident Report for Tamara

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 18:05 GMT+03:00

Identified

Dear valued Customers & Merchants,

We would like to inform you that we are currently experiencing an issue where customers may get stuck on the Payment Plan page, causing the screen to load indefinitely.

This issue is due to a third-party service outage, and our teams are actively working in a war room to troubleshoot and resolve the problem as quickly as possible.

📌 Impact:
Customers may be unable to complete down payments during this period.

We sincerely apologise for the inconvenience and will share an update as soon as the service is restored.

Thank you for your understanding.
Tamara
Posted Nov 18, 2025 - 17:55 GMT+03:00
This incident affected: Checkout.