Intermittent OTP issue affecting logins in KSA

Incident Report for Tamara

Resolved

This incident has been resolved.
Posted Dec 05, 2025 - 19:46 GMT+03:00

Identified

Dear valued merchants and customers,

We are currently experiencing an intermittent OTP issue in KSA that is preventing a subset of customers from logging in. As a backup, push notifications are enabled; however, this workaround may still impact some customers’ ability to log in and complete transactions.

Our teams are actively working in a war room with our service provider and have identified the source of the problem. We are prioritizing a fix and will provide updates as we make progress.

We apologize for the inconvenience and appreciate your patience.

Regards,

Tamara
Posted Dec 05, 2025 - 19:24 GMT+03:00
This incident affected: Customer App.